Client Support Team Temporarily Unavailable
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted May 03, 2024 - 14:39 EDT
Identified
Our Client Support team will be unavailable to answer live chats and phone calls on Friday, May 3, 2024 from 10:00am to 10:45am Eastern Standard Time. During this time you may leave a voicemail or send an email to support@asurint.com and we will respond as soon as possible.
Posted Apr 29, 2024 - 16:50 EDT