EEOC Files Lawsuit Against Employer Over Criminal Background Checks
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 12:13 EDT
Monitoring
On April 18, 2024, the Equal Employment Opportunity Commission (EEOC) filed a lawsuit against Sheetz, a convenience store chain, alleging the employer violated Title VII of the Civil Rights Act that prohibits disparate impact discrimination.

To read our blog post on this topic, please visit: https://www.asurint.com/resource-center/blog/april-2024/eeoc-files-lawsuit-against-employer-over-criminal-background-checks

Join us on Thursday April 25th at 12pm EDT to hear from Kelly Uebel, Asurint General Counsel, who will review this topic on Keeping Up with Compliance.

Register Here: https://go.asurint.com/keeping-up-with-compliance-q2-blog
Posted Apr 19, 2024 - 17:17 EDT