eScreen delays due to Hurricane Ida
Incident Report for Asurint
Resolved
*RESOLVED* eScreen delays due to Hurricane Ida
The backlog of shipping and testing specimens, due to hurricane Ida, has been completed. Transit and testing times are back to normal.
Posted Oct 07, 2021 - 16:28 EDT
Update
**eScreen Hurricane Ida Recovery Update**

eScreen continues to make progress with the backlog of samples impacted by Hurricane Ida. Their labs are operating 24/7 as they continue to work through the last remaining impacts of the storm.

* As of 9/20, all specimens delivered to their labs have been received and screened.
* Specimens requiring additional testing may experience additional delays, but should return to "standard turn-around times" by close of business October 8th.
* Results will continue to be released as they become available.

Thank you for your continued understanding and partnership!
Posted Sep 27, 2021 - 10:39 EDT
Update
We have good news!
FedEx has fully restored service to the New Orleans area. eScreen has accounted for the vast majority of specimens collected prior to the storm.

• As of September 20, eScreen has received and screened all specimens delivered to their laboratories to-date.
• Electronic collection records prior to September 5, for any specimen not yet received by the lab, will be canceled.
• If a test is still needed for those candidates and a ‘received at lab’ status is not indicated, a re-test is recommended.
• Specimens requiring additional testing may still experience delays.

We realize that you may have experienced delays in result reporting due to the complications of Hurricane Ida, and we thank you for your patience.
Posted Sep 21, 2021 - 14:48 EDT
Monitoring
We are continuing to monitor the situation to determine if the backlog of samples impacted from Hurricane Ida has been resolved.
Posted Sep 21, 2021 - 10:26 EDT
Identified
**UPDATE** eScreen delays due to Hurricane Ida

We are pleased to announce that power has been restored, via generators, to eScreen’s Gretna, LA lab and operations have resumed. Please note that, although operations has been restored at the lab, there will continue to be reporting delays of tested specimens as eScreen continues to work through the backlog of samples. However, eScreen is closely monitoring the recovery process and working through all outstanding specimens as quickly as possible.

Thank you again for your patience and understanding during this challenging time. Our thoughts and prayers continue to be with everyone impacted by this dangerous storm.
Posted Sep 03, 2021 - 17:10 EDT
This incident affected: Asurint | Data Availability.