St. Clair IL System Outage
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Aug 09, 2021 - 12:49 EDT
Monitoring
St. Clair is back online and we are working through the backlog of open orders.
Posted Jun 09, 2021 - 11:39 EDT
Identified
St. Clair Illinois county records are offline due to a recent cyberattack. The court is in the process of restoring record access but no timeline has been given. All open searches of St. Clair will be held until we can confirm full access is restored.
Posted Jun 07, 2021 - 10:12 EDT
This incident affected: Partnerships | United States Court System.