NSOPW Outages
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Jul 26, 2022 - 13:26 EDT
Update
We are continuing to monitor for any further issues.
Posted May 17, 2022 - 12:21 EDT
Monitoring
Beginning April 7th and continuing throughout May, the National Sex Offender Public Website (NSOPW) has experienced several periods of system outage. This may cause a turn-around time increase specific to this product. Our internal teams have been diligently working to complete impacted orders. At this time we do not have a backlog.

Please refer to our status.asurint.com for future updates.
Posted May 17, 2022 - 12:18 EDT
This incident affected: Asurint | Background Screening Platform.