Georgia MVR Delay
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Jan 19, 2021 - 08:12 EST
Monitoring
Georgia driving records are currently unavailable while the state updates their driving record system. Service is expected to be restored on Monday, January 18th. Georgia MVR reports can still be ordered but will be pending until service is restored.
Posted Jan 14, 2021 - 16:02 EST
This incident affected: Asurint | Data Availability.