Delays in Georgia

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 09:32 EST

Update

Please be advised of continued delays, primarily in; Gwinnett County. We will continue to provide updates.
Posted Nov 24, 2025 - 10:06 EST

Monitoring

Please expect delays, primarily in; Gwinnett County, as their website is currently down. We will continue to provide updates.
Posted Nov 20, 2025 - 09:37 EST
This incident affected: Asurint | Background Screening Platform and Asurint | Tenant Screening Platform.