Drug Testing Delays
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Mar 08, 2021 - 08:52 EST
Monitoring
Please be advised, eScreen’s laboratories have been impacted by the recent winter weather events across the country. The delay in receiving samples will not impact the accuracy of the test results. We apologize for the impact these delays may have and have been assured that eScreen is working diligently to process and test samples as they are delivered to the labs.
Posted Feb 25, 2021 - 08:18 EST
This incident affected: Asurint | Data Availability.