eScreen Service Advisory

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 08:30 EDT

Identified

eScreen is currently experiencing an outage affecting all services. Our team is actively monitoring the situation in close coordination with eScreen and will provide updates as more information becomes available.
Posted Oct 29, 2025 - 13:28 EDT
This incident affected: Asurint | Background Screening Platform.