Utah Statewide Delays

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 11:22 EDT

Monitoring

The Utah website is currently down and may cause potential delays with Utah statewide searches. We will continue to monitor and provide updates.
Posted Mar 10, 2025 - 15:09 EDT