Missouri Website

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Jun 19, 2023 - 09:33 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 07, 2023 - 09:23 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 07, 2023 - 14:13 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 23, 2023 - 09:34 EDT

Identified

An issue with the Missouri website has been identified and is causing some delay in order completion. We expect resolution shortly and will aggressively get through the resulting backlog.
Posted May 11, 2023 - 10:22 EDT