Verification Product TAT
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Dec 28, 2020 - 10:23 EST
Identified
Clients should expect a temporary increase in turnaround time (TAT) for Education and Employment Verification products. We are experiencing higher than normal volume levels and extended delays from both Employers and Education institutions. We apologize for this inconvenience and have adjusted the expected date on the applicable products, which can be seen on your in-progress report.
Posted Aug 20, 2020 - 13:33 EDT