Anticipated Delays Due To Hurricane Milton
Incident Report for Asurint
Update
Please see the updated list below for county court closures.

Charlotte
Citrus
Collier
DeSoto
Glades
Hendry
Hernando
Hillsborough
Lee
Manatee
Okeechobee
Pasco
Pinellas
Sarasota
Posted Oct 14, 2024 - 09:44 EDT
Update
Currently the following courthouses are confirmed closed.
LEVY
MARION
MIAMI-DADE
MONROE
NASSAU
OKEECHOBEE
PALM BEACH
PASCO
SARASOTA
ST. LUCIE
SUMTER
UNION
VOLUSIA
Posted Oct 09, 2024 - 16:48 EDT
Monitoring
Due to the potential impacts of Hurricane Milton, we anticipate possible delays and court closures. Currently the following courthouses are confirmed closed. We are actively monitoring the situation and will continue to provide updates.
LEVY
MARION
MIAMI-DADE
MONROE
NASSAU
OKEECHOBEE
PALM BEACH
PASCO
SARASOTA
ST. LUCIE
SUMTER
UNION
VOLUSIA
Posted Oct 08, 2024 - 08:46 EDT