Delays in Michigan

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 10:23 EDT

Monitoring

The Michigan website is currently down, impacting Michigan statewide searches. We will continue to monitor the situation closely and provide updates as they become available.
Posted Mar 25, 2025 - 10:26 EDT