Anticipated Delays Due to Hurricane Helene
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Oct 31, 2024 - 15:04 EDT
Update
Turnaround times have returned to normal for all counties, with the exception of clerk assisted searches in Richmond. We will continue to provide updates.
Posted Oct 24, 2024 - 10:09 EDT
Update
Please expect extended turnaround times for any clerk assisted searches in the following Georgia counties: Bulloch, Brooks, Coffee, Liberty, Richmond, Rockdale & Wayne.
Posted Oct 15, 2024 - 14:31 EDT
Update
We've identified potential delays in the following Georgia counties: Bulloch, Brooks, Coffee, Liberty, Wayne. Please expect extended turnaround times for any clerk assisted searches in these counties.
Posted Oct 03, 2024 - 14:31 EDT
Update
Delays may occur in Georgia, Florida and South Carolina for clerk assisted searches. We will continue to monitor the situation and provide updates.
Posted Oct 02, 2024 - 09:06 EDT
Monitoring
We continue to see delays due to the impact of Hurricane Helene. We will continue to provide updates.
Posted Sep 27, 2024 - 15:21 EDT
Identified
Due to the potential impacts of Hurricane Helene, we anticipate possible delays and court closures. We are actively monitoring the situation and will continue to provide updates.
Posted Sep 26, 2024 - 11:14 EDT