Delays in Allen, OH

Incident Report for Asurint

Update

The Lima municipal website is currently offline as part of their scheduled upgrade to a new case management system. The estimated completion date is 6/30. In the interim, we have implemented a workaround to ensure continued processing of affected orders.
Posted May 28, 2025 - 12:15 EDT

Update

Please continue to expect potential delays in Allen, OH as their website is currently down. We will continue to monitor the situation and provide updates.
Posted May 19, 2025 - 15:03 EDT

Update

Please continue to expect potential delays in Allen, OH as their website is currently down. We will continue to monitor the situation and provide updates.
Posted May 07, 2025 - 09:25 EDT

Monitoring

Please expect potential delays in Allen, OH as their website is currently down.
Posted Apr 28, 2025 - 08:52 EDT