Maine MVR Delays

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 08:47 EDT

Update

Maine driving records are still temporarily unavailable due to state maintenance. We are closely monitoring and will continue to provide updates.
Posted Jun 11, 2025 - 11:11 EDT

Identified

Maine driving records are temporarily unavailable due to state maintenance. We expect services to resume by the end of the day.
Posted Jun 10, 2025 - 14:22 EDT
This incident affected: Asurint | Background Screening Platform.