eScreen Service Advisory

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 15:57 EDT

Monitoring

eScreen is currently experiencing latency when generating documents such as ePassports. This may result in failures during event scheduling where document generation is required. Additionally, this may impact document retrievals for result certifications.

Our team is actively monitoring the situation in close coordination with eScreen and will provide updates as more information becomes available.
Posted Apr 23, 2026 - 11:22 EDT
This incident affected: Asurint | Background Screening Platform and Partnerships | Application Tracking Systems.