Delays in Orleans Parish, Louisiana

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 10:53 EDT

Update

We are continuing to experience issues with the Orleans Parish, LA website, which may result in delays. We will continue to provide updates.
Posted Mar 05, 2025 - 10:36 EST

Monitoring

Please expect delays in Orleans Parish, LA as their website is currently down. We will continue to provide updates.
Posted Feb 27, 2025 - 15:40 EST