Delays in St Clair, Illinois

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 16:55 EDT

Monitoring

Please expect delays in St Clair, Illinois, as the county's website is undergoing maintenance. We’ll continue to monitor the situation and provide updates as they become available.
Posted Jun 17, 2025 - 17:13 EDT
This incident affected: Asurint | Background Screening Platform.