MVR Service Disruption

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 08:30 EDT

Identified

We are currently experiencing an outage impacting Motor Vehicle Record (MVR) processing. Our team is actively working to determine resolution timing and will share updates as more information becomes available.
Posted Mar 24, 2026 - 13:46 EDT
This incident affected: Asurint | Background Screening Platform.