California MVR Delays

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 16:55 EDT

Identified

We have identified an issue causing delays with California MVRs. Our team is actively working to resolve the issue, and we will continue to provide updates.
Posted Jun 23, 2025 - 14:55 EDT
This incident affected: Asurint | Background Screening Platform.