Delays in Mississippi

Incident Report for Asurint

Update

Please expect continued delays for the following counties; Lee, Tate, Lowndes. These searches are clerk-assisted, and local courts are currently experiencing higher than usual volumes, which is contributing to slower turnaround times. We will continue to monitor and provide updates.
Posted Jan 26, 2026 - 11:10 EST

Monitoring

Please expect delays in Mississippi for the following counties; Lee, Pontotoc, Tate, Lowndes. These searches are clerk-assisted, and local courts are currently experiencing higher than usual volumes, which is contributing to slower turnaround times. We will continue to monitor and provide updates.
Posted Jan 14, 2026 - 13:10 EST
This incident affects: Asurint | Background Screening Platform and Asurint | Tenant Screening Platform.