Hinds, MS - cyber attack

Incident Report for Asurint

Resolved

We are actively working through the backlog of orders.
Posted Oct 05, 2023 - 15:34 EDT

Monitoring

Hinds County continues to be down due to cyber attack. They remain unable to complete any transactions.
Posted Sep 26, 2023 - 09:20 EDT

Identified

The court's offices have been closed as the result of a cyber attack. At this time, the court has not been able to provide an anticipated reopen date.
Posted Sep 15, 2023 - 13:57 EDT