Delays in Puerto Rico

Incident Report for Asurint

Update

The Puerto Rico Police Department continues to address the effects of a recent cyberattack, which has impacted their criminal records system. As a result, order processing in Puerto Rico may be delayed. We will continue to provide updates.
Posted Jun 30, 2025 - 09:54 EDT

Monitoring

Please expect delays in Puerto Rico due to a cyberattack that has impacted the Puerto Rico Police Department. We are actively monitoring the situation and will continue to provide updates.
Posted Jun 23, 2025 - 10:16 EDT
This incident affects: Asurint | Background Screening Platform.