Delays in Illinois

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted May 20, 2025 - 16:28 EDT

Monitoring

Please expect potential delays in Illinois due to intermittent website issues. We will continue to monitor and provide updates.
Posted May 16, 2025 - 08:49 EDT