Presidents Day Court Closures

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 12:30 EST

Monitoring

Please note that courts nationwide may be closed on Monday, February 16, in observance of Presidents Day. This may cause delays for any orders that require in‑person courthouse verification.
Posted Feb 13, 2026 - 11:41 EST
This incident affected: Asurint | Background Screening Platform and Asurint | Tenant Screening Platform.