Asurint Insights Updates

Incident Report for Asurint

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 10, 2025 - 21:46 EDT

Investigating

We are making updates to our reporting platform over the coming days. During this time, you may notice minor changes in the look and feel (e.g., a temporary removal of the Asurint logo). However, the platform is expected to remain fully functional, and no changes will be required to your current processes.
Thank you for your patience as we work to improve your experience. Please don’t hesitate to reach out with any questions.
Posted Jun 10, 2025 - 17:12 EDT
This incident affects: Asurint | Insights.