Delays in Florida

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted May 12, 2026 - 09:08 EDT

Monitoring

Please expect potential delays in the following Florida counties, as the Florida website is currently experiencing issues. We will continue to monitor and provide updates.

Impacted counties:

Baker
Bradford
Calhoun
Columbia
Deseto
Dixie
Franklin
Gilchrist
Glades
Gulf
Hamilton
Hardee
Hendry
Hernando
Highlands
Holmes
Jackson
Jefferson
Lafayette
Levy
Liberty
Madison
Marion
Nassau
Okeechobee
Pasco
Putnam
Santa rosa
Sumter
Union
Wakulla
Walton
Washington
Posted May 07, 2026 - 10:49 EDT
This incident affected: Asurint | Background Screening Platform and Asurint | Tenant Screening Platform.