Client Support Team Temporarily Unavailable - 02/13/2025

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 12:41 EST

Identified

Our Client Support team will be unavailable to answer live chats and phone calls on Thursday, February 13th, 2025 from 12:55pm-3:10pm, Eastern Standard Time. During this time you may leave a voicemail or send an email to support@asurint.com and we will respond as soon as possible.
Posted Feb 10, 2025 - 10:30 EST