Verification Product TAT - Holiday Delay
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 08:00 EST
Identified
Clients should expect a temporary increase in turnaround time (TAT) for Education and Employment Verification products during the holiday season. Many employers and education institutions are on extended leave and will delay their TAT in providing a verification.
Posted Dec 28, 2020 - 10:24 EST