Please be advised of continued delays, primarily in Pontotoc, Adams, Holmes, Lee, Lowndes and Hinds Counties. These searches are clerk-assisted, and local courts are currently experiencing higher than usual volumes, which is contributing to slower turnaround times.
Posted Aug 26, 2025 - 09:02 EDT
Monitoring
Please be advised of continued delays, primarily in Holmes, Hinds, Lee, and Lowndes Counties. These searches are clerk-assisted, and local courts are currently experiencing higher than usual volumes, which is contributing to slower turnaround times.
Posted Aug 19, 2025 - 15:06 EDT
Investigating
Please expect delays, primarily in Prentiss, Madison, Pike, DeSoto, Hinds, Jackson, and Rankin Counties. These searches are clerk-assisted, and local courts are currently experiencing higher than usual volumes, which is contributing to slower turnaround times.
We are closely monitoring the situation and will continue to provide updates.
Posted Jul 25, 2025 - 15:59 EDT
This incident affects: Asurint | Background Screening Platform.