Delays with FACIS product

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 12:38 EST

Identified

We are currently investigating an issue affecting the turnaround time on our Fraud and Abuse Control Information System (FACIS) product. Thank you for your patience while we work to bring this to a resolution.
Posted Jan 30, 2025 - 13:48 EST