Delays in Michigan
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 15:22 EDT
Update
The Michigan website is back up, and we expect to return to normal TAT by the end of the week. We will continue to provide updates.
Posted Sep 24, 2024 - 14:52 EDT
Update
The Michigan website is still down, impacting Michigan statewide searches. We will continue to provide updates as they become available.
Posted Sep 23, 2024 - 09:11 EDT
Update
Please be advised that the Michigan website is down again, impacting Michigan statewide searches. We will continue to provide updates as they become available.
Posted Sep 19, 2024 - 08:41 EDT
Monitoring
The Michigan website is back up, and we expect TAT to return to 24 hours by the end of the week. We will continue to provide updates.
Posted Sep 16, 2024 - 16:48 EDT
Identified
The Michigan website is currently down, impacting Michigan statewide searches. We will continue to monitor the situation closely and provide updates as they become available.
Posted Sep 13, 2024 - 17:13 EDT