Delays in Michigan

Incident Report for Asurint

Update

Recent updates to the state’s website may cause intermittent delays in order processing. We are actively managing these changes and have a process in place to minimize impact.
Posted May 28, 2025 - 12:53 EDT

Monitoring

Please expect potential delays in Michigan due to intermittent website issues. We will continue to monitor and provide updates.
Posted May 19, 2025 - 15:16 EDT