Cook County, IL
Incident Report for Asurint
Resolved
The Public Access Terminal is back up in Cook County.
Posted Apr 29, 2024 - 12:04 EDT
Update
After an outage, the Public Access Terminal is back up, please continue to expect delays as researchers are working through the backlog.
Posted Oct 27, 2023 - 13:25 EDT
Monitoring
The Cook County Clerk's website has been updated to display the following note: "Due to County Network issues, users may experience some slow response times when trying to access content on Odyssey Portal and Online Case Search. The issue is currently being worked on and should be resolved soon."
Posted Sep 28, 2023 - 09:27 EDT
Identified
Point of Access Terminals (PATs) at the court have been experiencing intermittent outages which is negatively impacting the ability to complete orders. Getting clerk assistance when the PATs are inoperable has been problematic as well. We continue to work through orders when the system is available.
Posted Aug 01, 2023 - 09:25 EDT