Delays in Georgia

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted May 27, 2026 - 09:17 EDT

Update

The Clayton, Georgia website is now operational. Please continue to expect delays, as these searches are clerk-assisted and experiencing higher than usual volumes. We will continue to monitor and provide updates.
Posted May 18, 2026 - 10:30 EDT

Monitoring

Please expect delays in Clayton, Georgia, as their website is currently down. We will continue to monitor the situation and provide updates.
Posted Apr 22, 2026 - 17:58 EDT
This incident affected: Asurint | Background Screening Platform and Asurint | Tenant Screening Platform.