Butler, OH website outage

Incident Report for Asurint

Resolved

The website for Hamilton is back up. We are currently working through the backlog of orders.
Posted May 26, 2023 - 10:41 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 26, 2023 - 10:40 EDT

Update

The website for Hamilton is back up. We are currently working through the backlog of orders.
Posted May 26, 2023 - 10:27 EDT

Identified

The Hamilton Muni website remains down in Butler, OH. Please expect delays for Butler, OH single county searches.
We continue to reach out to the municipality seeking information on the website will become available.
Posted May 16, 2023 - 11:14 EDT