Thanksgiving Holiday Office Closure

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 09:12 EST

Identified

In observance of Thanksgiving Day and the following day, Asurint offices will be closed on Thursday, November 27th, and Friday, November 28th, 2025.

We will resume normal business hours on Monday, December 1st, 2025.

We appreciate your understanding and wish you a wonderful and restful holiday!
Posted Nov 24, 2025 - 10:08 EST