Delays in Georgia

Incident Report for Asurint

Update

Please be advised of continued delays, primarily in Bibb, Richmond, Douglas and Houston Counties, due to intermittent issues with accessing court terminals and website outages. We will continue to monitor and provide updates.
Posted Aug 26, 2025 - 09:00 EDT

Update

Please be advised of continued delays, primarily in Bibb, Emanuel, Houston, Fulton, Richmond, and Muscogee Counties, due to intermittent issues with accessing court terminals and website outages. We will continue to monitor and provide updates.
Posted Aug 19, 2025 - 14:58 EDT

Monitoring

Please expect delays, primarily in Gwinnett County, due to intermittent issues with accessing court terminals and website outages. We will continue to provide updates.
Posted Jul 16, 2025 - 16:46 EDT
This incident affects: Asurint | Background Screening Platform.