Cleveland Ohio Municipal Court Delays

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 08:23 EDT

Monitoring

Court Operations have resumed and we anticipate improved turnaround times beginning 3/31.
Posted Mar 26, 2025 - 10:35 EDT

Update

At this time, the Cleveland Municipal courts will remain closed due to a cyber attack. We appreciate your patience as we work to identify alternative solutions.
Posted Mar 06, 2025 - 13:14 EST

Update

The Cleveland Municipal courts remain down, which may continue to cause delays in Cuyahoga County. We will continue to monitor and provide updates.
Posted Mar 05, 2025 - 09:37 EST

Identified

The Cleveland Municipal courts are currently down which may cause delays in Cuyahoga County. We will continue to monitor and provide updates.
Posted Feb 26, 2025 - 15:01 EST