Bentonville, AR - System Maintenance

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Sep 18, 2023 - 08:39 EDT

Identified

Public access at Bentonville District Court is down for maintenance and the court has not provided an ETA for when it will be operational again. Since public access is not available, we cannot complete searches currently.
Posted Sep 15, 2023 - 13:58 EDT