NSOPW Delays

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 11:00 EDT

Update

Please continue to expect delays in Puerto Rico. We will continue to monitor and provide updates.
Posted Jun 09, 2025 - 15:31 EDT

Investigating

Please expect potential delays due to multiple unavailable jurisdictions. We are actively monitoring the situation and will continue to provide updates.
Posted May 28, 2025 - 12:54 EDT