Delays in Ohio

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 09:51 EDT

Update

Please continue to expect potential delays, primarily in Licking and Hamilton Counties. We expect turnaround times to return to normal by 7/31.
Posted Jul 30, 2025 - 09:27 EDT

Monitoring

Please expect potential delays, primarily in Licking and Hamilton Counties, due to intermittent website outages. We are actively monitoring the situation and will continue to provide updates.
Posted Jul 16, 2025 - 16:45 EDT
This incident affected: Asurint | Background Screening Platform.