Delays in Cuyahoga County, Ohio

Incident Report for Asurint

Update

The Rocky River website is still down at this time. We will continue to provide updates.
Posted Jun 30, 2025 - 09:57 EDT

Monitoring

Please expect potential delays in Cuyahoga County, Ohio, as the Rocky River website is currently down. We will continue to monitor and provide updates.
Posted Jun 13, 2025 - 14:41 EDT
This incident affects: Asurint | Background Screening Platform.