Intermittent Delays in Asurint 2.0
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 08:24 EDT
Identified
You may be experiencing intermittent delays in the Asurint 2.0 platform. Please note that these delays will not impact your ability to place orders. We will continue to provide updates.
Posted Sep 30, 2024 - 12:58 EDT