Delays with FACIS product
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Jan 09, 2025 - 09:11 EST
Investigating
We are currently investigating an issue affecting the turnaround time on our Fraud and Abuse Control Information System (FACIS) based products. Thank you for your patience, while we work to bring this to a resolution.
Posted Jan 07, 2025 - 16:39 EST