Court Delays
Incident Report for Asurint
Update
Please review the link below for the most up-to-date court delays.

https://go.asurint.com/CourtClosures
Posted Apr 29, 2024 - 09:57 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2023 - 09:24 EDT
Monitoring
Please see the link below for an updated list of court status delays and closures as of June 13th.

https://go.asurint.com/CourtClosures
Posted Jun 08, 2023 - 09:24 EDT