Delays in Cobb, Georgia

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 08:53 EDT

Update

Cobb, GA remains down due to a possible cyberattack. We do not have an ETA on when they will reopen. We will continue to monitor the situation and provide updates as they become available.
Posted Mar 25, 2025 - 12:07 EDT

Monitoring

Please expect delays in Cobb, GA, as their website is currently down. We will continue to monitor the situation closely and provide updates as they become available.
Posted Mar 24, 2025 - 12:09 EDT