Hurricane Ian impacts

Incident Report for Asurint

Resolved

Based on communication received, the courts appear to have returned to business as usual.
Posted Oct 20, 2022 - 08:34 EDT

Investigating

Please be advised that we anticipate significant delays for orders impacted by Hurricane Ian. The storm is expected to impact Florida, Georgia, and other surrounding areas.
Posted Sep 28, 2022 - 11:52 EDT